Quick Guide: Ilevia X1 Plus
From connecting the Ilevia X1 Plus server to the first project with Ilevia Manager and Ilevia Control.
This guide takes you step by step from the installation of the Ilevia X1 Plus server to the creation of the first project with Ilevia Manager, and then to controlling the devices from the Ilevia Control app.
Server installation
Connect the server following the diagram of the X1 Plus server connections:
Power supply from 12 to 36 V DC;
Ethernet cable;
KNX bus cable;
2 RS485 serial ports (if used).
To access the system from outside the home as well, you can enable the X1 Plus server cloud connection.
Network settings
At startup, the server will automatically obtain the IP address from the router (DHCP server). It is important that the server is connected to the same network as the computer.
Connecting to the server: local connection
Open Ilevia Manager (downloadable from the download page). Go to the “Project” menu, then select the “Connect” command. The Connection window will appear. Now select the “Search” button to search for all servers on the network. The Server will appear in the Search results list with its name, IP address, and License ID.

Select the Server found in the search results to continue. Enter username and password (default credentials: “admin” and “password”, to be changed after the first configuration) and finally select OK to connect.

Connecting to the server: direct connection
If no router is available within the installation, or if you want to quickly program the Server, you can connect directly through the PC.
! Manual IP address setting
If there is no DHCP server or router assigning an IP address to the Server, you must set one manually. By default, it should be in the 192.168.1.x range.
> How to change network settings (disable DHCP and use a static IP address)
Step 1: Network adapters
Open the Windows Control Panel and go to Network and Sharing Center. Click Change adapter settings on the left side of the screen.

Step 2: Adapter properties
Right-click the Ethernet adapter (the one connected to the Server); the adapter properties window will open.

Step 3: IPv4
Scroll down the list until you find “Internet Protocol Version 4 (TCP/IPv4)” and click the Properties button to change the adapter IPv4 properties.

Step 4: IPv4 properties
Here you can assign a static IP address to the computer. Click the option “Use the following IP address:” and enter the IP address and subnet mask. The computer IP address must be different from the one used by the Server. By default, if there is no router, the Server IP address is 192.168.1.100: set the computer to a different address, for example 192.168.1.1 (simulating a router).
Press Enter after entering the IP address: the subnet mask will be filled in automatically with 255.255.255.0. That is fine: click OK and close the Network adapters window in Control Panel.

Firmware update
From time to time, new firmware updates are released, to be installed by following the procedure below.
Administrator panel
Turn on the server and connect it to your LAN network;
Open your web browser;
Copy the link and paste it into the search bar http://www.ilevia.com/evelocalip.php.
The browser will display a list of all Ilevia server IP addresses available on the local network. If only one Ilevia server is present on the local network, you will be automatically redirected to its web interface (as shown in the figure below).
Within the web interface you will find:

Log in with your username and password (default credentials are ‘admin’ and ‘password’). Once logged in, the navigation menu will be displayed.

Utility menu
Open the Utility section from the main menu;
Click Check now (Check now) to verify whether new firmware updates are available;
If a new firmware version is available, click Update (Update);
Wait for the system to restart, then you will be able to log in.

If the system is already updated to the latest firmware version, a message is displayed.

The complete procedure is in the Firmware update guide.
We will start by creating a project from scratch with the Ilevia Manager configuration software.
We will start by creating a project from scratch using the Ilevia Manager configuration software.
In the initial part, we will explain how to configure a switch component and how to set up a simple user interface.
Finally, we will explain how to upload an Ilevia project to the server and control the devices inside it from the Ilevia Control app.
1.1 Gateway creation
The Gateway section is made up of two different areas: Gateway and Gateway properties.
There are 4 preconfigured gateways, created by default and non-removable.

Now we will create a new gateway to connect the Ilevia server to the KNX bus.
Click the “+” icon in the upper-right corner within the Gateway section, or right-click and select add gateway. A new gateway will be created.


Set a title and select the KNX protocol from the protocol menu in the gateway properties.
If you have set the protocol to KNX/IP mode, enter the IP address of the KNX IP interface.
Change the port according to your configuration.

1.2 Component configuration
The Components section is made up of three different areas: Component library, My components and Component properties.
Drag a “SWITCH” component from the component library to the My components section.
Complete the Write and Feedback address fields in the component properties.
The Write and Feedback addresses correspond to the actuator connected to the KNX bus line.

1.3 Upload to server
Save the project, then select Project in the menu bar and then Upload to the server.
The project upload window will open. Make sure you enter the correct data.
Select Search and then the IP address of your Ilevia server.

Enter “admin” as the username and “password” as the project password (default credentials).
Select Ok and the current project will be uploaded to the Ilevia server.
1.4 Real-time connection
Select Project from the top menu and then Connect.

The connection window will be displayed. Make sure you enter the correct connection data.
Select Search and then the IP address of your Ilevia server.

Enter “admin” as the username and “password” as the project password (default credentials).
Select Ok and Ilevia Manager will connect to the Ilevia server.
Once connected, you can monitor the component status in real time.
If the configuration is incorrect, the text “N.A.” (not defined) will appear in the box showing the component status.


1.5 Creating the User Interface
NOTE
Ilevia allows you to configure 2 user interface styles (Classic and Maps), with different views.
Each user has their own user interface (Classic or Maps). The Classic interface is the default mode that Ilevia Manager lets you configure.
To control the home with both interface styles, you must create two different users and configure 2 different interfaces.
User Interface section. This section consists of two different areas:
1. Icons / My components (right area) which contains the icon sets and the configured components;
2. Interface grid (left area) where you will configure the user interface;
Select the Icons section, then drag an icon to the first row at the top left of the interface (Icons and scenarios level).
This is the first icon in the main menu of your new user interface.

Select the My components section, then drag the component into the interface grid on the left side of the screen (Components level).
This will create the components menu containing the newly added component.

1.6 Uploading the project to the server
Save the project, then select the Project menu at the top of the screen and then Upload.
The upload window will appear. Make sure you enter the correct credentials.
Select Search and then the IP address of your Ilevia server.
Enter “admin” as the username and “password” as the project password (default credentials).
Select Ok and the current project will be uploaded to the Ilevia server.

1.7 Accessing Ilevia Control
Launch the Ilevia Control app (mobile or desktop version).
Select the “+” icon in the upper-right corner of the screen. A new account will be created (Fig.1).
Set a title for the new account, then enter the IP address (or select it from the autosearch menu). Enter “admin” as the username and “password” as the password (default credentials), if not changed in the project (Fig. 2).
Once done, return to the main screen and select the newly created account to load and display the user interface (Fig. 3).
You can edit the account settings by dragging the account icon with your finger (or mouse pointer), as shown in the image below (Fig. 4).

Fig. 1

Fig. 2

Fig. 3

Fig. 4
1.8 Interface operation
Once the user interface has been loaded, this is what will be shown to the user (Classic user interface).
Click the icon to turn on or turn off the configured light.



This section of the guide explains step by step how to configure an Ilevia project starting from the import of KNX group addresses.
This section of the guide will explain step by step how to configure an Ilevia project starting from an import of KNX group addresses.
Here you will find all the basic information needed to create your first project using the Ilevia system.
Gateway creation
We start with an empty project. Select “File” from the top menu of Ilevia Manager and click “New”.
Now we proceed with creating a new KNX gateway that connects the Ilevia server to the KNX bus.
Refer to paragraph 1.1 “Gateway creation” in the chapter “Creating the first project”.
Component configuration
Move to the Components section.
Drag all the components you need from the component library to the “My components” area.
You can also organize the components into groups. Click the “+” icon in the upper right-hand area of the Components section.
This will create a new group, which you can rename as you prefer. Finally, drag the components inside it.

Step 1:
To begin, export the project from the ETS software and then import it into Ilevia Manager.
Right-click the chosen project, select Export and save it in a folder of your choice with the .esf (OPC EXPORT) extension.


Step 2:
Go to Ilevia Manager: select the Tools menu at the top of the screen, then “Import” → “ETS Groups”.

Step 3:
Upload the .esf file: once the file has been selected, a tree diagram with the group addresses previously created in ETS will be shown in a new window.


Step 4:
Select the component you want to configure from the “My components” area.
Drag the group address you want to associate with the component from the “ETS project” window, as shown in the image below.

Upload to the server
Save the project, then select “Project” from the main menu and then “Upload to server”.
A new window will open. Make sure to enter the correct credentials.
Select “OK”: the current project will be uploaded to the server.
Refer to paragraph 1.3 “Upload to server” in the chapter “Creating the first project”.
Real-time connection
Select “Project” from the main menu of Ilevia Manager and then “Connect”.
A new window will appear. Make sure to enter the correct credentials.
Finally select “OK”: you will be connected to the server automatically.
Once connected, it will be possible to verify in real time whether the component configuration is correct.
Refer to paragraph 1.4 “Real-time connection” in the chapter “Creating the first project”.
Remote connection
From Ilevia Manager:
To connect remotely to an X1, you need to know the public IP or DDNS assigned to the modem/router to which the Ilevia server is connected.
From Ilevia Control:
To make the connection work, you must open port 18000 to the outside, associated with the IP address of the X1 server, so you can access the system remotely as well.
You can test the service by disconnecting from the local network and accessing your Ilevia Control account with an LTE connection from your mobile device. If port 18000 has been opened correctly, the connection will take place instantly by tapping the account in the app.
Connection with the Auto resolve IP service:
The Ilevia Control app offers the possibility of connecting to the Ilevia server remotely without setting up two different accounts with two different IP addresses. With the Auto resolve IP option, you can use the same account without entering a public IP address in the settings. To enable it, make sure the “Auto resolve IP” checkbox is enabled in the account; remember that, for the option to work, port 18000 must be open. Finally, connect the mobile device to the local network and access the account.
Now, with an LTE connection, it will also be possible to access the account remotely.
Classic user interface
Select the “User interface” section.
Select the “Icons” section and then “Ilevia Icons” in the menu on the right side of the screen.
Drag the icons into the boxes in the left area of the screen (Icons and scenarios).

This will set the icons as the main menu (first level) of the user interface.
You can set a secondary menu linked to the icon configured at the first level.

Select the “My components” section, then drag the components into the interface (third and fourth level).
This will add the components to the secondary menu created previously.

You can also add optional subcomponents.
Subcomponents are useful with dimmable lights: as you can see in the image below, the component that adjusts light intensity is added in the subcomponents row.

Upload to the server
Save the project, then select “Project” from the main menu and then “Upload to server”.
A new window will open. Make sure you enter the correct credentials.
Select “OK”: the current project will be uploaded to the server.
See paragraph 1.3 “Upload to server” in the chapter “Creating the first project”.
Accessing Ilevia Control
Launch the Ilevia Control app.
Press the icon

located in the top-right corner of the app home screen.
Choose a title, then enter the IP address of the Ilevia server and the user credentials you want to use to log in.
Once setup is complete, return to the app home screen by clicking the icon

in the top-left corner.
See paragraph 1.7 “Accessing Ilevia Control” in the chapter “Creating the first project”.
Classic user interface operation
The images below show the result of the user interface created in Ilevia Manager.
The first icon you see is the one set at the first level of the interface, followed by all the others.
Select the main menu icon: you will be able to navigate through all the other menus and finally interact with the components as set in the Ilevia Manager project.




Try turning the light on and off from the app: you will notice the corresponding physical light change state.
Map-based user interface
We will now design a new user interface with a different style: the two user interface styles have a completely different layout. It will be necessary to create a new user in the Ilevia Manager project, because each user has its own interface style.
Creating a new User
So far we have worked on a single user (admin) and on its interface (current user).
Add a new user to the project: select “Users” in the main menu of Ilevia Manager, then click “New user”.
Clicking “New user” will open the “User management” window.

First of all, you need to know how to add a new user to your project.
You may have noticed the information displayed at the top of the Ilevia Manager window:
Connected user: admin – Current user: admin – Current project: n.d.

Choose a “Name” and a “Password” for the new user and confirm creation.
In this example, we chose the following credentials: Name: Map user – Password: password
You will be asked to choose which interface will be used for the new user.
Once “Interface style: Maps” is selected, additional settings will be shown, allowing you to apply preliminary settings to the user interface properties.
Once the new user is created, Ilevia Manager will select it automatically:
Connected user: admin – Current user: map user – Current project: n.d.

You can now start creating the new user’s interface.
Creating the Map-based interface
Select the User Interface section. The Map-based interface is made up of two different areas:
1. To add a new menu icon, click the “+” icon to access the Icons panel (right-hand area);
2. Interface area (left-hand area) where the actual interface will be created.


Select the “Icons” section and open the “Ilevia Icons” group on the right side of the screen.
Drag the icons into the left pane, where you can add icons or scenes.
This will configure the icon that will be the main menu (main bar) of our user interface.
You can edit the icon by double-clicking it with the left mouse button: the icon “Editor” menu will open.

It is now possible to set the secondary menu associated with the selected main menu icon.
To create a new submenu, click the icon

immediately after the “Untitled” section at the top of the interface panel.
Each main menu can have an indefinite number of submenus.

By double-clicking the submenu, you can change its name and icon.

Now we will focus on the interface area where the components to be controlled are placed.
You can edit the interface area using the commands shown below for background settings.
“File selection” lets you choose the background image for the selected submenu.
You can choose whether to display it or not and select the background color of the specific submenu.


Drag the components you want to add to the user interface into the editor canvas.

You can now edit these icons: by double-clicking them with the left mouse button, you will enter the icon editor.
Map interface operation
This is the visual result of the interface just created in the Ilevia Manager configuration software.
The first icon displayed will correspond to the main menu of your interface.
The icons displayed at the top or bottom of the interface correspond to the submenus created.
The central area of the interface editor lets you create a complete interface with a background image and related components.

Switch components are represented as empty light bulbs when in the Off state, and they fill up when the light switches to the On state.
Try turning the light on and off from the interface: you will notice that the connected light changes state.
