Quick guide: Ilevia X5 virtual machine
From installing the Ilevia X5 virtual machine to the first project with Ilevia Manager and Ilevia Control.
This guide takes you step by step from installing the Ilevia X5 virtual machine to creating the first project with Ilevia Manager, up to controlling the components from the Ilevia Control app. ciao
Server installation
The virtual machine is an application environment that emulates hardware resources: the Ilevia server runs without a dedicated physical device.
Network settings
Start the virtual machine: the server will automatically obtain the IP address from the router (DHCP server). It is important that the server is reachable from the same network as the computer, so you can use the Connect command within Ilevia Manager.
Connection to the server: local connection
Open Ilevia Manager (available from the download page). Go to the “Project” menu, then select the “Connect” command. The Connection window will appear. Now select the “Search” button to search for all servers on the network. The Server will appear in the Search results list with its name, IP address and License ID.

Select the Server in the search results to continue. Enter username and password (default credentials: “admin” and “password”, to be changed after the first configuration) and finally select OK to connect.

Firmware update
New firmware updates are released from time to time, to be installed by following the procedure below.
Administrator panel
Turn on the server and connect it to your LAN network;
Open your web browser;
Copy the link and paste it into the search bar http://www.ilevia.com/evelocalip.php.
The browser will display a list of all Ilevia server IP addresses available on the local network. If there is only one Ilevia server on the local network, you will be automatically redirected to its web interface (as shown in the figure below).
Within the web interface you will find:

Log in with your username and password (the default credentials are ‘admin’ and ‘password’). Once logged in, the navigation menu will be displayed.

Utility menu
Open the Utility section from the main menu;
Click Check now (Check now) to check for new firmware updates;
If a new firmware version is available, click Update (Update);
Wait for the system to restart, then you will be able to log in.

If the system is already updated to the latest firmware version, a message is displayed.

The complete procedure is in the Firmware update guide.
We will start by creating a project from scratch with the Ilevia Manager configuration software.
We will start by creating a project from scratch using the Ilevia Manager configuration software.
In the first part, we will look at how to configure a switch component and how to set up a simple user interface.
Finally, we will explain how to upload an Ilevia project to the server and control the components inside it from the Ilevia Control app.
1.1 Gateway creation
The Gateway section consists of two different areas: Gateway and Gateway properties.
There are 4 preconfigured gateways, created by default and cannot be removed.

Now we will create a new gateway to connect the Ilevia server to the KNX bus.
Click the “+” icon in the upper-right corner within the Gateway section, or right-click and select add gateway. A new gateway will be created.


Set a title and select the KNX protocol from the protocol menu within the gateway properties.
If you have set the protocol in KNX/IP mode, enter the IP address of the KNX IP interface.
Change the port according to your configuration.

1.2 Component configuration
The Components section consists of three different areas: Component library, My components and Component properties.
Drag a “SWITCH” component from the component library to the My components section.
Fill in the Write and Feedback address fields within the component properties.
The Write and Feedback address correspond to the actuator connected to the KNX bus line.

1.3 Upload to server
Save the project, then select Project in the menu bar and then Upload to the server.
The project upload window will open. Make sure you enter the correct data.
Select Search and then the IP address of your Ilevia server.

Enter “admin” as the username and “password” as the project password (default credentials).
Select Ok and the current project will be uploaded to the Ilevia server.
1.4 Real-time connection
Select Project from the top menu and then Connect.

The connection window will be displayed. Make sure you enter the correct connection details.
Select Search and then the IP address of your Ilevia server.

Enter “admin” as the username and “password” as the project password (default credentials).
Select Ok and Ilevia Manager will connect to the Ilevia server.
Once connected, it will be possible to monitor the component status in real time.
If the configuration is incorrect, the text “N.D.” (not defined) will appear in the panel showing the component status.


1.5 User Interface Creation
NOTE
Ilevia allows you to configure 2 user interface styles (Classic and Map-based), with different displays.
Each user has their own user interface (Classic or Map-based). The Classic interface is the default mode that Ilevia Manager allows you to configure.
To control the home with both interface styles, you must create two different users and configure 2 different interfaces.
User Interface section. This section is made up of two different areas:
1. Icons / My components (right area) which contains the icon sets and configured components;
2. Interface grid (left area) where you will configure the user interface;
Select the Icons section, then drag an icon into the first row at the top left of the interface (Icons and scenarios level).
This is the first icon of the main menu of your new user interface.

Select the My components section, then drag the component into the interface grid on the left side of the screen (Components level).
This will create the components menu with the newly added component inside it.

1.6 Uploading the project to the server
Save the project, then select the Project menu at the top of the screen and then Upload.
The upload window to the server will appear. Make sure you enter the correct credentials.
Select Search and then the IP address of your Ilevia server.
Enter “admin” as the username and “password” as the project password (default credentials).
Select Ok and the current project will be uploaded to the Ilevia server.

1.7 Accessing Ilevia Control
Launch the Ilevia Control app (mobile or desktop version).
Select the “+” icon in the top right corner of the screen. A new account will be created (Fig.1).
Set a title for the new account, then enter the IP address (or select it from the autosearch menu). Enter “admin” as the username and “password” as the password (default credentials), if they have not been changed in the project (Fig. 2).
Once done, go back to the main screen and select the newly created account to load and display the user interface (Fig. 3).
You can edit the account settings by dragging the account icon with your finger (or mouse pointer), as shown in the image below (Fig. 4).

Fig. 1

Fig. 2

Fig. 3

Fig. 4
1.8 Interface operation
Once the user interface has been loaded, this is what will be shown to the user (Classic user interface).
Click the icon to turn on or turn off the configured light.



This section of the guide explains step by step how to configure an Ilevia project starting from the import of KNX group addresses.
This section of the guide explains step by step how to configure an Ilevia project starting from an import of KNX group addresses.
Here you will find all the basic information to create your first project using the Ilevia system.
Gateway creation
Let's start with an empty project. Select “File” from the top menu of Ilevia Manager and click “New”.
Now let’s create a new KNX gateway that connects the Ilevia server to the KNX bus.
See paragraph 1.1 “Gateway creation” of the chapter “Creating the first project”.
Component configuration
Let's move to the Components section.
Drag all the components you need from the component library to the “My components” area.
You can also organize components into groups. Click the “+” icon in the upper-right section of Components.
This will create a new group, which you can rename as you wish. Finally, drag the components into it.

Step 1:
To begin, export the project from ETS software, then import it into Ilevia Manager.
Right-click the selected project, choose Export, and save it in a folder of your choice with the .esf (OPC EXPORT) extension.


Step 2:
Move to Ilevia Manager: select the Tools menu at the top of the screen, then “Import” → “ETS Groups”.

Step 3:
Upload the .esf file: once the file is selected, a tree diagram with the group addresses previously created in ETS will be displayed in a new window.


Step 4:
Select the component you want to configure from the “My components” area.
Drag the group address you want to associate with the component from the “ETS project” window, as shown in the image below.

Upload to the server
Save the project, then select “Project” from the main menu and then “Upload to server”.
A new window will open. Make sure you enter the correct credentials.
Select “OK”: the current project will be uploaded to the server.
See paragraph 1.3 “Upload to server” in the chapter “Creating the first project”.
Real-time connection
Select “Project” from the Ilevia Manager main menu and then “Connect”.
A new window will appear. Make sure you enter the correct credentials.
Finally, select “OK”: you will be automatically connected to the server.
Once connected, you can verify in real time whether the component configuration is correct.
See paragraph 1.4 “Real-time connection” in the chapter “Creating the first project”.
Remote connection
From Ilevia Manager:
To connect remotely to an X1, you need to know the public IP or DDNS assigned to the modem/router to which the Ilevia server is connected.
From Ilevia Control:
To make the connection work, you must open port 18000 to the outside, associated with the IP address of the X1 server, so you can access the system remotely as well.
You can test the service by disconnecting from the local network and accessing your Ilevia Control account with an LTE connection from the mobile device. If port 18000 has been opened correctly, the connection will be established instantly by clicking the account in the app.
Connection with the Auto resolve IP service:
The Ilevia Control app allows you to connect remotely to the Ilevia server without setting up two different accounts with two different IP addresses. With the Auto resolve IP option, you can use the same account without entering a public IP address in the settings. To enable it, make sure the “Auto resolve IP” checkbox is selected on the account; remember that, for the option to work, port 18000 must be open. Finally, connect the mobile device to the local network and log in to the account.
Now, with an LTE connection, it will be possible to access the account remotely as well.
Classic user interface
Select the “User interface” section.
Select the “Icons” section, then “Ilevia Icons” in the menu on the right side of the screen.
Drag the icons into the boxes in the left area of the screen (Icons and scenarios).

This will set the icons as the main menu (first level) of the user interface.
You can set a secondary menu related to the icon set at the first level.

Select the “My components” section, then drag the components into the interface (third and fourth level).
This will add the components to the secondary menu created previously.

You can also add optional subcomponents.
Subcomponents are useful with dimmable lights: as you can see in the image below, the component that adjusts light intensity is added in the subcomponents row.

Upload to the server
Save the project, then select “Project” from the main menu and then “Upload to server”.
A new window will open. Make sure you enter the correct credentials.
Select “OK”: the current project will be uploaded to the server.
See paragraph 1.3 “Upload to server” in the chapter “Creating the first project”.
Access to Ilevia Control
Launch the Ilevia Control app.
Press the icon

located in the upper-right corner of the main screen of the application.
Choose a title, then enter the Ilevia server IP address and the credentials of the user you want to log in with.
Once the settings are complete, return to the application home page by clicking the icon

at the top left.
See paragraph 1.7 “Accessing Ilevia Control” in the chapter “Creating the first project”.
Classic user interface operation
The images below show the result of the user interface created in Ilevia Manager.
The first icon you see is the one set at the first level of the interface, followed by all the others.
Select the main menu icon: you can navigate through all the other menus and finally interact with the components as configured in the Ilevia Manager project.




Try turning the light on and off from the app: you will see the corresponding physical light change state.
Map user interface
We will now move on to designing a new user interface with a different style: the two user interface styles have a completely different layout. You will need to create a new user in the Ilevia Manager project, because each user has its own interface style.
Creating a new User
So far, we have worked on a single user (admin) and its interface (current user).
Add a new user to the project: select “Users” in the main Ilevia Manager menu, then click “New user”.
Clicking “New user” will open the “User management” window.

First of all, you need to know how to add a new user to your project.
You may have noticed the information shown at the top of the Ilevia Manager window:
Connected user: admin – Current user: admin – Current project: n.d.

Choose a “Name” and a “Password” for the new user and confirm creation.
In this example, we chose the following credentials: Name: Map user – Password: password
You will be asked to choose which interface will be used for the new user.
Once “Interface style: Maps” is selected, additional settings will be shown, allowing preliminary settings to be applied to the user interface properties.
Once the new user is created, Ilevia Manager will select it automatically:
Connected user: admin – Current user: map user – Current project: n.d.

You can now start creating the new user's interface.
Creating the Map interface
Select the User Interface section. The Map interface is made up of two different areas:
1. To add a new Menu Icon, click the “+” icon to access the Icons panel (right area);
2. Interface area (left area) where the actual interface will be created.


Select the “Icons” section and open the “Ilevia Icons” group on the right side of the screen.
Drag the icons into the left pane, where you can add icons or scenarios.
This will configure the icon that will be the main menu (main bar) of our user interface.
You can edit the icon by double-clicking it with the left mouse button: the icon’s “Editor” menu will open.

You can now set the secondary menu related to the selected main menu icon.
To create a new sub menu, click the icon

immediately after the “Untitled” section at the top of the interface pane.
Each main menu corresponds to an indefinite number of secondary menus.

By double-clicking the secondary menu, you can change its name and icon.

Now we will focus on the interface area where the components to be controlled are inserted.
You can modify the interface area using the commands shown below for background settings.
“File selection” lets you choose the background image for the selected secondary menu.
You can choose whether to make it visible or not and select the background color of the specific secondary menu.


Drag into the editor canvas the components you want to add to the user interface.

You can now edit these icons: by double-clicking them with the left mouse button, you will enter the icon editor.
Map interface operation
This is the visual result of the interface just created in the configuration software Ilevia Manager.
The first icon displayed will be the one corresponding to the main menu of your interface.
The icons displayed at the top or bottom of the interface correspond to the secondary menus created.
The central area of the interface editor allows you to create a complete interface with a background image and related components.

Switch components are represented as empty bulbs when in the Off state, which fill up when the light switches to the On state.
Try turning the light on and off from the interface: you will notice that the light connected to that component changes state.
